PerNet
管理员
管理员
  • UID2
  • 粉丝24
  • 关注1
  • 发帖数89
  • 社区居民
  • 忠实会员
  • 喜欢达人
  • 原创写手
阅读:707回复:0

The next version of cryptography will drop support for Python 2.6

楼主#
更多 发布于:2017-10-13 11:54
/usr/lib64/python2.6/site-packages/cryptography/__init__.py:26: DeprecationWarning: Python 2.6 is no longer supported by the Python core team, please upgrade your Python. The next version of cryptography will drop support for Python 2.6



/usr/lib64/python2.6/site-packages/cryptography/__init__.py:26: DeprecationWarning: Python 2.6 is no longer supported by the Python core team, please upgrade your Python. The next version of cryptography will drop support for Python 2.6


在限制urllib3所应用的配置的ssl模块,在某些Python版本(特别是2.7.9之前的)有限制,特别的是,这导致HTTPS请求在本来更多的功能平台成功的变成失败,还有导致某些安全功能模块失效。
如果你遇到这个警告,强烈建议升级到高版本的python版本,或者在OpenSSL/PyOpenSSL部分描述的,你要使用pyOpenSSL。



继续查找了一下解决办法:
https://github.com/plotly/plotly.py/issues/339




按照文章的解决办法,使用$ pip install requests[security] 即可,安装完之后不再有警告。
这个将会安装pyOpenSSL,ndg-httpsclient,pyasn1。
/usr/lib64/python2.6/site-packages/cryptography/__init__.py:26: DeprecationWarning: Python 2.6 is no longer supported by the Python core team, please upgrade your Python. The next version of cryptography will drop support for Python 2.6 用pip安装第三方库时总是提示:You are using pip version 8.0.2, however version 8.1.0 is available.
pip install --upgrade pip



用此命令之前,python环境先要安装pip。pip是安装管理python包的工具。
喜欢0 评分0
游客

返回顶部